Ticket #327 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

SIPS URI in Contact header generated by pjsua causing problems with OpenSER

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.8.0
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Since 0.7.0, when TLS transport is being used, PJSUA-LIB will generate "sips:" URI scheme for the Contact header.

This causes OpenSER-1.1.0-tls to fail to forward any requests to the user agent. The remote agent will receive this status code:

SIP/2.0 500 I'm terribly sorry, server error occurred (1/TM)

while OpenSER log shows these log messages:

11(1062) ERROR: uri2proxy: bad transport  for sips uri: 3
11(1062) ERROR:tm:t_forward_nonack: failure to add branches

According to http://openser.org/pipermail/users/2007-February/009417.html, this is caused by OpenSER only accepting transport=tcp URI parameter when sips: is used.

Change History

comment:1 Changed 10 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r1353

Now there is PJSUA_SECURE_SCHEME macro/setting in pjsua.h to control what URI scheme should be used when TLS transport is being used. Default is sip.

comment:2 Changed 10 years ago by bennylp

Another fix in r1354 (this time really changed default URI scheme for TLS to sip).

Note: See TracTickets for help on using tickets.