Opened 3 weeks ago

Closed 3 weeks ago

#2203 closed defect (fixed)

Failure to set minimum SSL version when OpenSSL 1.1 is used

Reported by: ming Owned by: ming
Priority: normal Milestone: release-2.9
Component: pjlib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by ming)

When OpenSSL 1.1 installed, it is not possible to set a minimum TLS version anymore, for example via PJSIP_SSL_DEFAULT_PROTO in config_site.h. Instead, PJSIP offers/accept always all versions of the underlying OpenSSL library.

This is caused by ticket #1999.

Thanks to Alexander Traud for the report and the patch.

Change History (2)

comment:1 Changed 3 weeks ago by ming

  • Description modified (diff)

comment:2 Changed 3 weeks ago by ming

  • Owner set to ming
  • Resolution set to fixed
  • Status changed from new to closed

In 6006:

Fixed #2203: Failure to set minimum SSL version when OpenSSL 1.1 is used

Note: See TracTickets for help on using tickets.