Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#2168 closed defect (fixed)

Add media event for audio device error

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-2.9
Component: pjmedia-audiodev Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Reported that WMME audio device thread could be suddenly stopped in a long duration call (about 8 hours or so). Unfortunately it is quite difficult to investigate the cause. So a workaround is to notify app when it happens so app can restart the audio device.

Thanks Mario Ban for the report.

Change History (2)

comment:1 Changed 12 months ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In 5920:

Close #2168: Added media event for audio device error.

comment:2 Changed 12 months ago by nanang

In 5923:

Re #2168:

  • Added a new PJSUA callback on_media_event().
  • Added audio device error handling into PJSUA2.
Note: See TracTickets for help on using tickets.