Ticket #1917 (closed defect: fixed)

Opened 19 months ago

Last modified 18 months ago

Miscellaneous fixes

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.5.1
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Miscellaneous updates and fixes.

Change History

comment:1 Changed 19 months ago by ming

In 5295:

Re #1917 (misc): Fixed pj_getaddrinfo()'s CFHost version (such as on iOS) which may return truncated IP address if (af == PJ_AF_UNSPEC) and the address is of IPv6 family.

Thanks to Johan Lantz for the fix.

comment:2 Changed 19 months ago by ming

In 5296:

Re #1917 (misc): Fixed memory leak in pj_stun_sock_start() if pj_getaddrinfo() fails

comment:3 Changed 18 months ago by riza

In 5299:

Re #1917(misc): Update README.txt including the one on third_party folder.

Thanks to Alexander Traud for the report.

comment:4 Changed 18 months ago by riza

In 5300:

Re #1917(misc): When enabling libsamplerate, the current source code expects to
have the already installed package "libsamplerate" in the third-party directory
of pjproject. The patch changes this.

Thanks to Alexander Traud for the patch.

comment:5 Changed 18 months ago by riza

In 5309:

Re #1917 (misc): Change how PJMEDIA_VIDEO_DEV_SDL_HAS_OPENGL is declared in config.h. It needs to be enabled manually.

comment:6 Changed 18 months ago by riza

In 5310:

Re #1917 (misc): Replace obsolete command (since autoconf 2) on aconfigure.ac.

Thanks to Alexander Traud for the patch.

comment:7 Changed 18 months ago by riza

In 5312:

Re #1917(misc): Fix tpipv6.h not found when enabling IPv6 on Visual Studio.

comment:8 Changed 18 months ago by nanang

In 5313:

Misc (re #1917): Added capability of receiving incoming call in pjsua2_demo.cpp.

comment:9 Changed 18 months ago by riza

In 5315:

Re #1917(misc): Update how PJMEDIA_VIDEO_DEV_HAS_OPENGL is define.

comment:10 Changed 18 months ago by ming

In 5317:

Re #1917 (misc): Suppress empty-body warning and "logical not is only applied to the left hand side of this comparison" warning

comment:11 Changed 18 months ago by nanang

In 5318:

Misc (re #1917): Fixed pjsua build error of 'exception handling disabled' on Android.

comment:12 Changed 18 months ago by nanang

In 5320:

Misc (re #1917): Disable ALSA audio device backend on BB10 in config_site_sample.h.

comment:13 Changed 18 months ago by nanang

In 5321:

Misc (re #1917): Missed inline implementation of pjmedia_snd_get_dev_count(), see also #1907 (thanks Marcus Froeschl for the report).

comment:14 Changed 18 months ago by nanang

In 5324:

Misc (re #1917): Reset media provisional count in adding video after media initialization fails.

comment:15 Changed 18 months ago by ming

In 5325:

Re #1917: Related to ticket #1311, sets the factory on transports created as a result of an accept as well.

Thanks to George Joseph for the patch.

comment:16 Changed 18 months ago by nanang

In 5327:

Misc (re #1917): Print warning (instead of returning error) in creating SIP UDP transport IPv6 with STUN enabled.

comment:17 Changed 18 months ago by riza

In 5328:

Re #1917 (misc): Fix failed pjlib-test when built using Visual Studio 2015 caused by defined EINVAL with different string error.

comment:18 Changed 18 months ago by riza

In 5330:

Re #1917(misc): Fix failed purity_test() on pjlib-test since getaddrinfo() might return multiple addrinfo.

comment:19 Changed 18 months ago by riza

  • Status changed from new to closed
  • Resolution set to fixed

In r5331:

Re #1917(misc): Fix silly mistake on r5330.

Note: See TracTickets for help on using tickets.