Ticket #1867 (closed enhancement: fixed)

Opened 3 years ago

Last modified 3 years ago

Add pjsua callback to notify when STUN resolution completes

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.4.5
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Calling #pjsua_init() will initiate an async process to resolve and contact each of the STUN server entries to find which is usable. This callback is called when the process is complete, and can be used by the application to start creating and registering accounts. This way, the accounts can avoid call setup delay caused by pending STUN resolution.

Change History

comment:1 Changed 3 years ago by ming

  • Status changed from new to closed
  • Resolution set to fixed

In 5131:

Fixed #1867: Add pjsua callback to notify when STUN resolution completes

Note: See TracTickets for help on using tickets.