Opened 5 years ago

Closed 4 years ago

#1842 closed task (fixed)

Unit tests review

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.4.5
Component: unit-tests Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Mainly focus on fixing spurious test results. This ticket is also a continuation of #1828.

Change History (9)

comment:1 Changed 5 years ago by nanang

In 5065:

Re #1842: Updated pjsua app to avoid stdout buffering, and also adjusted python tests accordingly.

comment:2 Changed 5 years ago by nanang

In 5066:

Re #1842: Fixed build error on cmp_wav tool for python tests due to changed pjmedia format structure in 2.x.

comment:3 Changed 5 years ago by nanang

In 5067:

Re #1842:

  • Updated python test driver run.py to perform stdout polling using a dedicated thread, this will increase the robustness of pattern matcing class "Expect" and remove the possibility of stucked pjsua (due to output buffer full when no stdout read polling is done).
  • Also updated other test driver and scenario accordingly.

comment:4 Changed 5 years ago by nanang

In 5068:

Re #1842: Minor update on python test to reduce possibility of EADDRINUSE error in running pjsua.

comment:5 Changed 5 years ago by nanang

In 5071:

Re #1842: Workaround for spurious failure in sipp/uac-reinvite-bad-via-branch.xml test, i.e: just retry the scenario. The failure is caused by race between SIPp sending re-INVITE vs transaction immediate termination (by SIP INVITE module when the session reaches CONFIRMED state).

comment:6 Changed 5 years ago by nanang

In 5072:

Re #1842: Still on sipp/uac-reinvite-bad-via-branch.xml, fixed missing stuff in retry scenario, e.g: sequence number increment, To tag, wait for old tsx destroy.

comment:7 Changed 4 years ago by nanang

In 5155:

Re #1842: Added automated test scenarios for Android and iOS 64-bit

comment:8 Changed 4 years ago by nanang

In 5156:

Re #1842: Updated automated test scenarios to invoke 'make distclean' first.

comment:9 Changed 4 years ago by riza

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.