Changes between Version 1 and Version 3 of Ticket #1835


Ignore:
Timestamp:
Apr 7, 2015 1:58:27 AM (7 years ago)
Author:
ming
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1835

    • Property Status changed from new to closed
    • Property Resolution changed from to fixed
  • Ticket #1835 – Description

    v1 v3  
    11The current iOS OpenGL renderer has two problems: 
    2 - Crash when created in the background 
    3 When app accepts video call when in bg, without going to foreground, creating OpenGL context will crash. 
     2- Crash when created in the background.[[br]] 
     3  When app accepts video call when in bg, without going to foreground, creating OpenGL context will crash. 
    44 
    55- Assertion caused by race condition between rendering and destruction 
     6{{{ 
    67Assertion failed: (vid_tee && vid_tee->info.signature==( 'E'<<24 | 'T'<<16 | 'V'<<8 | 'P' )), function pjmedia_vid_tee_remove_dst_port, file ../src/pjmedia/vid_tee.c, line 277. 
    78 
     
    1011#6      0x001dd894 in stop_media_stream at pjproject-2.0-iphone/pjsip/build/../src/pjsua-lib/pjsua_media.c:2238 
    1112#7      0x001dcc10 in stop_media_session [inlined] at pjproject-2.0-iphone/pjsip/build/../src/pjsua-lib/pjsua_media.c:2285 
     13}}}