Opened 4 years ago

Closed 13 months ago

#1830 closed enhancement (duplicate)

Option to maintain video aspect ratio between requested size and supported size

Reported by: nanang Owned by: nanang
Priority: normal Milestone: Known-Issues-and-Ideas
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Currently, video port has to handle video resizing when video size requested by application is not supported by video device. A raised issue is how to find the closest size from the supported sizes, e.g: should we consider same/closest aspect ratio in the search?

After a discussion, we come to a conclusion that the priority is the closest width, then closest height (when resized with same aspect ratio), and eventually the result may have different aspect ratio. So perhaps we should provide options whether aspect ratio should be maintained and how (crop or pad with black boxes at up&down/left&right sides).

Change History (1)

comment:1 Changed 13 months ago by nanang

  • Resolution set to duplicate
  • Status changed from new to closed

TeluuCon? 2018: duplicate of #1831.

Note: See TracTickets for help on using tickets.