Opened 4 years ago

Closed 4 years ago

#1827 closed defect (fixed)

Video port's clock thread may get stuck during format change event

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.4
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

It's caused by two things:

  • Video port's clock thread try to stop its own thread from within itself.
  • On some platforms pj_thread_join() do not perform check when called from within itself.

Change History (1)

comment:1 Changed 4 years ago by ming

  • Resolution set to fixed
  • Status changed from new to closed

In 5012:

Fixed #1827: Video port's clock thread may get stuck during format change event

Note: See TracTickets for help on using tickets.