Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1818 closed defect (fixed)

Fixed destruction of locked mutex

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.4
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

As detected by Helgrind tool

Change History (3)

comment:1 Changed 7 years ago by ming

  • Resolution set to fixed
  • Status changed from new to closed

In 4987:

Fixed #1818: Fixed destruction of locked mutex (thanks to Denis Poltorak for the Helgrind report)

comment:2 Changed 7 years ago by ming

In 4988:

Re #1818: Fixed destruction of locked mutex in sip transport

comment:3 Changed 7 years ago by ming

In 5043:

Re #1818: Avoid warning caused by trying to destroy a locked jb mutex in pjmedia stream

Note: See TracTickets for help on using tickets.