Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1782 closed defect (fixed)

Miscellaneous fixes

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.4
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Miscellaneous updates and fixes.

Change History (51)

comment:1 Changed 5 years ago by ming

In 4916:

Re #1782 (misc): Removes ffmpeg libraries from XCode project.

comment:2 Changed 5 years ago by nanang

In 4917:

Misc (re #1782): Fixed compile error of ios_opengl_dev.m on iOS 8 SDK due to missing OpenGLES headers (thanks Brian Walker for the report and the fix).

comment:3 Changed 5 years ago by nanang

In 4932:

[SIPit31] Misc (re #1782): Updated AMR parser behavior, i.e: from raising assertion to just printing log and also discard the whole packet, on receiving invalid AMR frame-type.

comment:4 Changed 5 years ago by ming

In 4933:

Re #1782 (misc): Fixed missing add_ref() in pjsip_tsx_retransmit_no_state() (thanks to Itay Bianco for the patch)

comment:5 Changed 5 years ago by ming

In 4934:

Re #1782 (misc): Clone sdp attribute fmtp and rtpmap before adding it in process_pending_reinvite()

comment:6 Changed 5 years ago by ming

In 4935:

Re #1782 (misc): Do not copy the public address and bound address if pjsua_acc_modify()'s new setting doesn't change those

(thanks to Povilas Krilius for the report)

Last edited 5 years ago by ming (previous) (diff)

comment:7 Changed 5 years ago by ming

In 4937:

Re #1782 (misc): Fixed bug caused by wrong order of code made in r4933 (thanks to Brian Walker for noticing this)

comment:8 Changed 5 years ago by ming

In 4938:

Re #1782 (misc): Only perform unregistration in pjsua_acc_modify() if the reg_uri is valid

comment:9 Changed 5 years ago by riza

In 4939:

Misc (re #1782): Change field name unregWaitSec to unregWaitMsec, as it represents millisecond data. (Thanks to Chris Updegraft for the feedback).

comment:10 Changed 5 years ago by riza

In 4940:

Misc (re #1782): Update the xcode interface builder (xib) file for iPad.

comment:11 Changed 5 years ago by riza

In 4941:

Misc (re #1782): Support for Russian language for sound device name when using WMME. This should also work for other language with special character set. (Thanks Alexander Fatyanov for the patch).

comment:12 Changed 5 years ago by riza

In 4942:

Misc (re #1782): Avoid assertion when updating keep alive. Assert scenario: register, switchoff network adapter and immediately request unregister. This issue is intermittent. (Thanks to Alexander Fotyanov for the patch).

comment:13 Changed 5 years ago by riza

In 4943:

Misc (re #1782): Fixed silly error from r4941. (Additional thanks Max Bondarenko for the original patch).

comment:14 Changed 5 years ago by riza

In 4945:

Misc (re #1782): In case if STUN server is configured and NAT-traversal is in process user can delete this server from setting list. In that case in internal_stun_resolve_cb we should check that STUN server is available. (Thanks to Max Bondarenko for the patch).

comment:15 Changed 5 years ago by ming

In 4946:

Re #1782 (misc): Fixed preprocessor definition of PJMEDIA_WMME_DEV_USE_MMDEVICE_API (thanks to Sean Bright for the patch)

comment:16 Changed 5 years ago by riza

In 4947:

Misc (re #1782): Fixed unregistration sent twice when calling pjsua_acc_modify with reg_uri is blank.

comment:17 Changed 5 years ago by ming

In 4950:

Re #1782 (misc): Fixed return value of AudioMedia::getTxLevel()/getRxLevel()
to be in the range of 0-100, as stated in the doc

comment:18 Changed 5 years ago by riza

In 4951:

Misc (re #1782): Fixed initialize Dshow failed when the COM library already initialized.

comment:19 Changed 5 years ago by nanang

In 4953:

Misc (re #1782): Skip libyuv and libopenh264 lookups when passing '--disable-video' param to configure script (thanks Sean Bright for the patch).

comment:20 Changed 5 years ago by nanang

In 4958:

Misc (re #1782): Print log message when SIP UDP transport is destroyed.

comment:21 Changed 5 years ago by ming

In 4959:

Re #1782 (misc):
This is related to #1249: Memory corruption bug in splitcomb. The fix r3548 in that ticket was accidentally reversed in r3664.

Thanks to David Richards for the report.

Last edited 5 years ago by ming (previous) (diff)

comment:22 Changed 5 years ago by ming

In 4961:

Re #1782 (misc): This is related to #1418: Library restart fails with PJLIB_UTIL_ESTUNNOTRESPOND error after several times. The fix r3896 in that ticket was accidentally modified during merging in r3999.

comment:23 Changed 5 years ago by riza

In 4962:

Re #1782 (misc): Fixed crash when failing to create filter graph on dshow.
Thanks to Alexander Fatyanov for the report.

comment:24 Changed 5 years ago by nanang

In 4964:

Misc (re #1782): Fixed exchanged timer I timeout value (for absorbing any additonal ACK before shifting tsx state to terminated) between reliable vs unreliable transports.

comment:25 Changed 5 years ago by nanang

In r4965:

Fixed bug of missing SIP header "Supported: outbound, path" after a registration failure (thanks Mateusz Olejnik for the report).

comment:26 Changed 5 years ago by nanang

In 4966:

Misc (re #1782): Fixed OpenSSL detection in configure script due to incomplete dependencies and bad library order, which causes OpenSSL detection failure on some platform such as Android mips and arm64.

comment:27 Changed 5 years ago by riza

In 4972:

Re #1782 (misc): Change assert check of ssl_state to non assert check on OpenSSL wrapper implementation.

(thanks to Joshua Colp for the suggestion)

comment:28 Changed 5 years ago by ming

In 4975:

Re #1782 (misc): Do not include SDP when sending 181 response (patch provided by Joshua Colp)

comment:29 Changed 5 years ago by ming

In 4977:

Re #1782 (misc): Fixed inaccurate TX packet loss percentage and stats calculation.

comment:30 Changed 5 years ago by ming

In 4979:

Re #1782 (misc): Prevent buffer overrun in pjsip message/uri printing
Thanks to Sagi Iltus for the patch

comment:31 Changed 5 years ago by nanang

In 4981:

Misc (re #1782): added compile-time settings for Speex AGC & denoiser in Speex AEC, note that both are enabled by default, as previously AGC was enabled (by pjmedia, as it seems to improve AEC performance) and denoiser was also enabled by default by Speex.

comment:32 Changed 5 years ago by nanang

In 4984:

Misc (re #1782): Enabled G722 in config_site_sample.h for iOS and Android platforms.

comment:33 Changed 5 years ago by ming

In 4990:

Re #1782 (misc): Fixed unitialized mutex owner variable when creating mutex

comment:34 Changed 5 years ago by ming

In 4991:

Re #1782 (misc): Suppress Helgrind's warning about possible data race when doing ioq select.

comment:35 Changed 5 years ago by nanang

In 4993:

Misc (re #1782): Applied OpenH264 CFLAGS/LDFLAGS probing result by configure script into Makefile.

comment:36 Changed 5 years ago by riza

In 5000:

Misc (re #1782): Check if the transport being shutdown in on_accept_complete and on_connect_complete callback

comment:37 Changed 5 years ago by nanang

In 5005:

Misc (re #1782): Setup log writer function on pjsua CLI (useful for debugging library initialization).

comment:38 Changed 5 years ago by nanang

In 5015:

Misc (re #1782): Update default OpenH264 video size for Android platforms to 352x288.

comment:39 Changed 5 years ago by nanang

In 5017:

Misc (re #1782): Coding style works (indentation, etc) on Android pjsua2 sample app codes.

comment:40 Changed 5 years ago by ming

In 5041:

Re #1782 (misc): Improve layout in ipjsua sample app, so it can display both preview and incoming video together.

comment:41 Changed 5 years ago by ming

In 5042:

Re #1782 (misc): Prevent build error if using another ioqueue backend (such as epoll) or if using PJ_CONFIG_MAXIMUM_SIZE on platforms that do not support setting FD_SETSIZE

comment:42 Changed 5 years ago by ming

In 5044:

Re #1782 (misc): Fixed activesock's lock msg w.r.t iOS background to be more precise.

comment:43 Changed 5 years ago by nanang

In 5045:

Misc (re #1782): Fixed various compile warnings on MSVC.

comment:44 Changed 5 years ago by nanang

In 5046:

Misc (re #1782): Fixed various compile warnings on MacOS & iOS.

comment:45 Changed 5 years ago by riza

In 5048:

Misc (re #1782): Fixed SIP error code not set properly when there's an error in initializing media channel. Thanks to Roman Kublin for the report.

comment:46 Changed 5 years ago by riza

In 5049:

Misc (re #1782): Check if capturer is opened when getting window information. On slow devices (iPhone 3GS) the capturer might not be opened when the format changed is requested.

comment:47 Changed 5 years ago by ming

In 5053:

Re #1782 (misc): (trivial)Fixed typo in log

comment:48 Changed 5 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

comment:49 Changed 5 years ago by riza

In 5059:

Misc (re #1782): Add information to pjsip_endpt_send_request documentation that the timeout param is not implemented yet.

comment:50 Changed 5 years ago by nanang

In 5060:

Misc (re #1782): Suppress compile warnings on MSVC.

comment:51 Changed 5 years ago by riza

In 5061:

Misc (re #1782): Fixed build error when using PJ_POOL_DEBUG=1

Note: See TracTickets for help on using tickets.