Opened 6 years ago

Closed 6 years ago

#1745 closed defect (fixed)

Problems in building shared/dynamic libraries on MinGW

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.2.1
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by nanang)

Known issues:

  1. Multiple definition of pj_time_decode/pj_time_encode.
  2. Missing LDFLAGS on some components.
  3. pjmedia-audiodev depends on pjmedia/format.c.

Thanks Brian White for the report.

Change History (4)

comment:1 Changed 6 years ago by nanang

In 4784:

Re #1745 (Shared lib on MinGW): Fixed multiple definition of pj_time_decode/encode().

comment:2 Changed 6 years ago by nanang

In 4785:

Re #1745 (Shared lib on MinGW): Avoid circular dependency caused by pjmedia-audiodev dependency on pjmedia/format.c for pjmedia_format_init_audio().

comment:3 Changed 6 years ago by nanang

In 4786:

Re #1745 (Shared lib on MinGW): Fixed missing LDFLAGS setting on some components and build options for win32 DLL.

comment:4 Changed 6 years ago by nanang

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.