Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1716 closed enhancement (fixed)

New Android application based on pjsua2+SWIG API

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: applications Version: trunk
Keywords: pjsua2 Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by nanang)

The application is located under pjsip-apps/src/swig/java/android. Check this wiki for build info.

Change History (9)

comment:1 Changed 6 years ago by nanang

In 4691:

Re #1716: Initial implementation of new Android app based on pjsua2+SWIG API.

comment:2 Changed 6 years ago by nanang

In 4693:

Re #1716: Handle recreated activity, for example by device rotation.

comment:3 Changed 6 years ago by riza

In 4696:

Re #1716:Added java desktop sample application.

comment:4 Changed 6 years ago by nanang

In r4697:

  • Misc fixes/updates on Android app based on pjsua2+SWIG, e.g: fixed java string comparisons, added build config for ndk-build (for native debugging), updates on SVN props.

comment:5 Changed 6 years ago by nanang

In 4698:

Re #1716: Maintain reference to log writer to avoid crash (caused by premature cleanup by GC).

comment:6 Changed 6 years ago by bennylp

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 6 years ago by nanang

In 4733:

Re #1716: Fixed crash in adding buddy, caused by immediate buddy state notification right after adding buddy to account, while UI buddy list has not been updated yet.

comment:8 Changed 6 years ago by nanang

  • Description modified (diff)

comment:9 Changed 6 years ago by nanang

In 4734:

Re #1716, misc updates:

  • always enable ICE+STUN
  • UI: added textEmailAddress to SIP URI inputs
Note: See TracTickets for help on using tickets.