Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1712 closed defect (fixed)

Must not send BYE before ACK is received

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

According to http://tools.ietf.org/html/rfc3261#section-15:

   However, the callee's UA MUST NOT send a BYE on a confirmed dialog
   until it has received an ACK for its 2xx response or until the server
   transaction times out.

Change History (2)

comment:1 Changed 6 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

In 4653:

Fixed #1712: Must not send BYE before ACK is received

comment:2 Changed 6 years ago by bennylp

In r4754:

Handle case when 200/OK times-out because it's not ACKed and inv needs to send BYE. In this case, ACK will never be received so don't wait for it. Similar treatment for transport error

Note: See TracTickets for help on using tickets.