Ticket #1664 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Ioqueue epoll stops processing socket events

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: pjlib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Reported that it is caused by the bug in handling error events in ioqueue epoll so the error events will never be cleared, and when the number of the unhandled error events reaches MAX_EVENTS_IN_SINGLE_POLL, any future events will never been processed/delivered to app by ioqueue epoll.

Change History

comment:1 Changed 6 years ago by nanang

  • Status changed from new to closed
  • Resolution set to fixed

In 4515:

Fixed #1664: Fixed the bug of unhandled error events in non-connecting socket state in ioqueue epoll.

comment:2 Changed 6 years ago by ming

In 4528:

Re #1664: Fixed wrong handling of poll error

Note: See TracTickets for help on using tickets.