Opened 7 years ago

Closed 7 years ago

#1649 closed defect (fixed)

SIP TLS transport not destroyed after verification error

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.2
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description

Reported that on SIP TLS transport failure caused by TLS verification error, the
socket descriptor is not released, so after several (auto) re-registration
attempts, the application will run out of descriptor and getting error such as
"Too many open files".

Change History (1)

comment:1 Changed 7 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In 4450:

Fix #1649: Invoke SIP TLS transport callback when transport is shutdown by TLS certificate verification error.

Note: See TracTickets for help on using tickets.