Opened 12 years ago

Closed 12 years ago

#164 closed defect (fixed)

Bug in pjmedia_stream_resume() not resuming the stream (thanks PurnaChandar and Carmine)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-0.7.0-rc1
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

(this is duplicate of ticket #163 for the trunk).

There is a bug in pjmedia_stream_resume(), it sets the paused flag to 1 while it should reset it to zero!!

While were at it, also fix the following:

  • when pjmedia_stream_pause() is called, jitter buffer should be reset so that any left-over frames will be cleared (otherwise it would be played next time pjmedia_stream_resume() is called).
  • during pause state, any incoming RTP packets should not be put in the jitter buffer.

Change History (1)

comment:1 Changed 12 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r1048.

Note: See TracTickets for help on using tickets.