Opened 6 years ago

Closed 6 years ago

#1605 closed defect (fixed)

Cannot enable video via pjsua_call_reinvite2()/update2()

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.1
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by nanang)

Reproducing steps:

  1. A makes a video call to B, with vid_cnt == 1 in the call setting.
  2. B rejects the video
  3. A tries to enable video by sending re-INVITE with vid_cnt == 1 in the new call setting.
  4. The SDP offer sent by A still has video media line disabled (port zero).

After investigation, the SDP generation for the re-INVITE doesn't initialize the video media, technically because the pjsua_media_channel_init() is skipped due to "no update" on media count setting (vid_cnt in this case). So it is the check of media-count-update that is actually buggy.

Thanks Itay Bianco for the report.

Change History (2)

comment:1 Changed 6 years ago by nanang

  • Description modified (diff)

comment:2 Changed 6 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In 4315:

Fix #1605: always re-init media channel for SDP re-offer/answer generation.

Note: See TracTickets for help on using tickets.