Ticket #1598 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Fixed assertion when sip error code is not set (thanks Peter Koletzki for the report)

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-2.1
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description (last modified by ming) (diff)

PJSIP is throwing an assertion at sip_util.c when during executing pjsua_start(), an incoming call is received.

This is caused by:

  1. pjsua_call.c / pjsua_call_on_incoming():

sip_err_code is uninitialized

  1. pjsua_media.c / pjsua_media_channel_init()

when pjsua_get_status() != RUNNING, the function will return without setting the sip_err_code. This creates a response with random sip error code and an assertion is thrown.

Change History

comment:1 Changed 6 years ago by ming

  • Description modified (diff)

comment:2 Changed 6 years ago by ming

  • Status changed from new to closed
  • Resolution set to fixed

In 4306:

Fixed #1598: Assertion when sip error code is not set (thanks Peter Koletzki for the report)

Note: See TracTickets for help on using tickets.