Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1568 closed enhancement (fixed)

Smarter media re-initialization on call refresh with SDP re-offer/answer

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.1
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: release-1.16 Backported: yes

Description

Always re-initializing the media on call refresh can be annoying, especially for a call with video as video re-init may take several seconds.

Thanks Matynka Bartosz for the feedback.

Change History (11)

comment:1 Changed 7 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In 4254:

Close #1568:

  • Added media change detection based on SDP negotiation result and local codec param settings, the detection result will decide whether the media should be re-initialized after the SDP negotiation.
  • Fixed stream to keep the duplicate of codec param for the stream info (was only copying the pointer).
  • Introduced macro PJSUA_THIRD_PARTY_STREAM_HAS_GET_INFO & PJSUA_THIRD_PARTY_STREAM_HAS_GET_STAT.

comment:2 Changed 7 years ago by ming

Last edited 7 years ago by ming (previous) (diff)

comment:3 Changed 6 years ago by bennylp

  • Backport to 1.x milestone set to release-1.16

comment:4 Changed 6 years ago by nanang

In 4329:

Re #1568: backported to 1.x branch.

comment:5 Changed 6 years ago by nanang

  • Backported set

comment:6 Changed 6 years ago by ming

In 4334:

Re #1568: Fixed is_media_changed() detection when pjsua_media_cfg.no_vad is set to PJ_TRUE and fixed the string duplication of encoding name
Thanks to Hideo and Fredrik for the reports.

comment:7 Changed 6 years ago by ming

In 4336:

Re #1568: (PJSIP 2.x) Apply pjsua_media_config before detecting media change and fixed encoding name string duplication.

comment:8 Changed 6 years ago by ming

In 4337:

Re #1568: (PJSIP 1.x) Apply pjsua_media_config before detecting media change

comment:9 Changed 6 years ago by nanang

In 4338:

Re #1568: (only for 1.x) media transport should be (re)started even when media is unchanged.

comment:10 Changed 6 years ago by nanang

In 4345:

Re #1568: (PJSIP 2.x) No need to restart media when remote RTP address changed but ICE transport is running.

comment:11 Changed 6 years ago by nanang

In 4346:

Re #1568: (PJSIP 1.x) No need to restart media when remote RTP address changed but ICE transport is running.

Note: See TracTickets for help on using tickets.