Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1566 closed defect (fixed)

Metallic audio on audio+video call with audio codec G.722

Reported by: nanang Owned by: nanang
Priority: normal Milestone: release-2.1
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: release-1.16 Backported: yes

Description

Reported that G.722 audio has metallic reverberation only when video is active.

This is easily reproducible with pjsua using param "--video --add-codec G722 sip:localhost".

After investigation, we found out that in the beginning of call, some G.722 RTP packets use clock rate 16kHz (for about first 15 packets) and the rest of the session use 8kHz, so the stream receiver thinks that remote uses 16kHz for G.722 RTP packets for the whole G.722 audio session (see also #486 about RFC bug on G.722 clock rate). Those first bad packets are actually silence frames generated by stream when it has no transmitter (in the conference bridge) in the beginning of the call (seems to be caused by media setup lag).

Thanks Matynka Bartosz for the report.

Change History (3)

comment:1 Changed 7 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In 4223:

Fixed #1566:

  • Increased RTP check count from 5 to 50.
  • Immediate stop check when the correct RTP ts span, i.e: using 8khz clockrate, is received.

comment:2 Changed 6 years ago by ming

In 4391:

Re #1566: Backported to 1.x

comment:3 Changed 6 years ago by ming

  • Backported set
Note: See TracTickets for help on using tickets.