Opened 7 years ago

Closed 6 years ago

#1562 closed defect (fixed)

Miscellaneous fixes

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-2.1
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported: no

Description


Change History (22)

comment:1 Changed 7 years ago by nanang

In 4216:

Re #1562: fixed typo in pjsua app video option help: the default for "--vrender-dev" should be "-2".

comment:2 Changed 7 years ago by nanang

In 4225:

Re #1562: Added compile-time setting to enable/disable "c=" line in SDP session level. The default is disabled.

comment:3 Changed 7 years ago by ming

In 4234:

Re #1562: Fixed compilation error if PJMEDIA_HAS_PASSTHROUGH_CODECS is enabled

comment:4 Changed 7 years ago by nanang

In 4239:

Misc (re #1562): fixed compile warnings on Win platform (some are reported as compile error on Symbian).

comment:5 Changed 7 years ago by ming

In 4241:

Re #1562: Add support for I420 format in DShow video device.

comment:6 Changed 7 years ago by bennylp

In 4246:

Misc (re #1562): pkgconfig removed multiple occurences of -framework from Libs command-line causing link error (thanks Samuel Vinson for the report)

comment:7 Changed 7 years ago by ming

In 4253:

Re #1562: Add support for multiple GUIDs that represents the same format (such as I420/IYUV) in DShow device.

comment:8 Changed 7 years ago by ming

In 4257:

Re #1562: Add PJMEDIA_HAS_VIDEO macro for vid_stream_info

comment:9 Changed 6 years ago by nanang

In 4276:

Misc (re #1562): pkgconfig removed duplicated framework name from Libs without removing the '-framework' option itself, which caused link error.

comment:10 Changed 6 years ago by nanang

In 4277:

Misc (re #1562): Fixed ffmpeg codec wrapper compile error of undefined 'AVCodec::encode' (removed in the recent ffmpeg version).

comment:11 Changed 6 years ago by ming

In 4279:

Re #1562: Fixed default custom media transport creation callback flag. By default, custom media transport should close its member transport.

comment:12 Changed 6 years ago by ming

In 4290:

Re #1562 (misc): Fixed uninitialized frame for conversion in video port

comment:13 Changed 6 years ago by nanang

In 4294:

Misc (re #1562): Fixed Symbian build errors on S60 5th edition SDK.

comment:14 Changed 6 years ago by bennylp

In 4297:

Re #1562: PJSUA-LIB shutdown operation may block for a long time if system time is modified while the shutdown is in progress. Also fixed similar issue in STUN client.

comment:15 Changed 6 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed 6 years ago by bennylp

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:17 Changed 6 years ago by bennylp

In 4305:

Misc (re #1562): Add a protection in med_tp_timer_cb() against call that may have been terminated before ICE callback is called. It has been reported that this has caused a crash, but we cannot reproduce it. Thanks Karina for the report.

comment:18 Changed 6 years ago by nanang

In 4311:

Misc (re #1562): Update ffmpeg version check regarding 'AVCodec::encode' removal (see also r4277).

comment:19 Changed 6 years ago by nanang

In 4341:

Misc (re #1562): pjsua_call_set_vid_strm() should acquire call dialog.

comment:20 Changed 6 years ago by nanang

In 4358:

Misc (re #1562): Minor updates in pjsua app: fixed wrong error message and increased buffer for input menu.

comment:21 Changed 6 years ago by bennylp

In 4369:

Misc re #1562: disable trace in the jitter buffer

comment:22 Changed 6 years ago by ming

  • Milestone changed from release-2.2 to release-2.1
  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.