Opened 8 years ago

Closed 8 years ago

#1483 closed defect (fixed)

Unexpected re-registration in modifying account config

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-1.14
Component: pjsua-lib Version: common
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Modifying account config settings, i.e: via pjsua_acc_modify(), is not supposed to always trigger re-registration, for example modifying call or media settings such as SIP session timer, SRTP settings. However, such unexpected re-registration case has been found.

After investigation, it seems to be caused by that proxy setting is mistakenly detected as being modified. The proxy change detection is done using CRC comparison, and the initial CRC calculation in pjsua_acc_add() is performed before the proxy URI normalization.

Change History (1)

comment:1 Changed 8 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

(In [4039]) Fix #1483: make sure that the CRC calculation of account proxy setting is done after proxy URI normalization.

Note: See TracTickets for help on using tickets.