Opened 12 years ago

Closed 12 years ago

#142 closed defect (fixed)

Crash on Linux when USB sound card set as the first sound card (thanks Sergei Petrov)

Reported by: bennylp Owned by: bennylp
Priority: major Milestone: release-0.7.0-rc1
Component: pjmedia Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Quoting http://pjsip.org/pipermail/pjsip/2007-February/002312.html:

My problem is the following, i've got two sound cards, one built-in
intel8x0, and the other one generic usb-audio. pjsua works fine when
i've got both cards active and the built-in one is the first card in
ALSA. When I make the USB card the first one, the pjsua segfaults with
a message:

12:49:56.491 os_core_unix.c Info: possibly re-registering existing thread

Other sound apps work fine in both configurations.

Thanks Sergei Petrov for reporting.

See also ticket #141 for the stable branch.

Change History (1)

comment:1 Changed 12 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Crash on Linux when USB sound card set as the first sound card to Crash on Linux when USB sound card set as the first sound card (thanks Sergei Petrov)

Sergei Petrov wrote:

I've found out that the problem is in portaudio. In function
static void Copy_16_To_16 ()
in the pa_converters.c file the dest buffer happens to be NULL
somehow, I've made a quick fix that works for me like
if (dest == NULL) return;

Fixed in r1012.

Note: See TracTickets for help on using tickets.