Opened 8 years ago

Closed 8 years ago

#1393 closed defect (fixed)

Miscellaneous fixes

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-2.0-beta
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description


Change History (23)

comment:1 Changed 8 years ago by bennylp

(In [3836]) Misc (re #1393): increase default H.263 bandwidth

comment:2 Changed 8 years ago by nanang

(In [3838]) Misc (re #1393): Put log warning in ffmpeg codecs when a codec is enabled but cannot be found in ffmpeg library.

comment:3 Changed 8 years ago by bennylp

(In [3839]) Misc (re #1393): fixed wrong libavutil version detection

comment:4 Changed 8 years ago by bennylp

(In [3852]) Misc (re #1393): crash in vid win command without argument

comment:5 Changed 8 years ago by nanang

(In [3857]) Misc (re #1393): cosmetic in call dump, missing '=' char in avg bitrate in TX :)

comment:6 Changed 8 years ago by bennylp

(In [3866]) Re #1393 (misc): remove unnecessary call to start preview renderer in video update

comment:7 Changed 8 years ago by bennylp

in r3870: added info about ICE candidates being used (both local and remote) in pjsua dump call output

comment:8 Changed 8 years ago by bennylp

(In [3874]) Misc (re #1393): disable jbuf tracing

comment:9 Changed 8 years ago by bennylp

(In [3875]) Misc (re #1393): write log if adding pjsua buddy fails

comment:10 Changed 8 years ago by bennylp

(In [3887]) Missing video component deinitialization caused assertion when the stack is restarted. Thanks Régis Montoya for the report (re #1393)

comment:11 Changed 8 years ago by bennylp

(In [3890]) Fixed problem with selecting audio codec if rtpmap is omitted from the SDP for the static PT (re #1393, thanks Régis Montoya for the fix!)

comment:12 Changed 8 years ago by nanang

(In [3892]) Misc (re #1393): fix linking error "app_config_init_video() not found" when video is disabled, also some compile warnings (unused variables).

comment:13 Changed 8 years ago by bennylp

(In [3894]) Minor (re #1393): fixed compilation warning in pjsua app if video is disabled

comment:14 Changed 8 years ago by nanang

(In [3909]) Misc (re #1393): fix compile error in pjsua_media.c (undefined member 'bitrate' in struct 'pjmedia_format') when using passthrough codec.

comment:15 Changed 8 years ago by nanang

(In [3910]) Misc (re #1393): fix compile error in pjmedia-codec/audio_codecs.c, caused by typo and wrong member reference: '&c->passthough.ilbc' should be '&c->passthrough.setting'.

comment:16 Changed 8 years ago by nanang

(In [3917]) Misc (re #1393): fix bitrate calculation in stream.c and wav_playlist.c.

comment:17 Changed 8 years ago by bennylp

(In [3921]) Re #1393 (misc): renamed label on_error to on_return and fixed warning re constness

comment:18 Changed 8 years ago by bennylp

(In [3922]) Re #1393 (misc): reduced default ffmpeg h264 bandwidth from 512 to 256kbps

comment:19 Changed 8 years ago by bennylp

(In [3923]) Misc (re #1393): vidgui: added account and NAT support and fixed assertion on incoming call

comment:20 Changed 8 years ago by bennylp

(In [3926]) Re #1393: added checkbox to enable/disable video in vidgui sample app

comment:21 Changed 8 years ago by bennylp

(In [3927]) re #1393: error in detecting libavformat in mac os if ffmpeg was built and libbzip2-dev is installed. This caused ffmpeg to be built with dependency to libbz2, while our configure does not, causing link error during libavformat detection. This is temporarily fixed by adding libbz2 detection in aconfigure.ac

comment:22 Changed 8 years ago by nanang

(In [3930]) Misc (re #1393): vidgui: fixed zombie video window after re-INVITE by always destroying any incoming video window first before processing media update.

comment:23 Changed 8 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.