Opened 8 years ago

Closed 8 years ago

#1370 closed defect (fixed)

Miscellaneous

Reported by: ming Owned by: bennylp
Priority: minor Milestone: release-2.0-alpha2
Component: common Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Small and miscellaneous commits go here.

Change History (19)

comment:1 Changed 8 years ago by ming

(In [3750]) Re #1370: Use GCD instead of NSThread for iOS video device.

comment:2 Changed 8 years ago by bennylp

(In [3757]) Misc video (re #1370): ignore return value of sws_scale() as it returned zero on Linux in some conversion, although the resulting picture looks okay

comment:3 Changed 8 years ago by nanang

(In [3773]) Misc video (re #1370): fixed function definition specifier of pjmedia_vid_tee_remove_dst_port().

comment:4 Changed 8 years ago by bennylp

(In [3783]) Misc (re #1370): open v4l2 in blocking mode to get rid of Resource temporarily unavailable error

comment:5 Changed 8 years ago by bennylp

(In [3784]) Misc (re #1370): minor fix in pjsua_vid_preview_get_win() documentation which said it will return NULL instead of PJSUA_INVALID_ID if the window is not created for the device

comment:6 Changed 8 years ago by bennylp

(In [3785]) Misc (re #1370): auto arranging of video windows in pjsua

comment:7 Changed 8 years ago by bennylp

(In [3789]) Fixed link error in pjsua due to r3785 (Misc, re #1370)

comment:8 Changed 8 years ago by nanang

(In [3790]) Misc (re #1370): minor fix compile warning on VS2005 about comparison between int & unsigned int.

comment:9 Changed 8 years ago by bennylp

(In [3791]) Misc (re #1370): removed dead code in session.c

comment:10 Changed 8 years ago by bennylp

(In [3792]) Misc (re #1370): vid_dev_stream should not call start() if it is already been started

comment:11 Changed 8 years ago by bennylp

(In [3793]) Misc (re #1370): calling pjmedia_vid_port_start() more than once had caused freezing capture video if preview is enabled before making video calls

comment:12 Changed 8 years ago by ming

(In [3797]) Re #1370: Fixed dshow enumeration device capability.

comment:13 Changed 8 years ago by bennylp

(In [3798]) Misc (re #1370): rename command "vid call set-cap" to "vid call cap", and added command "vid win arrange" to auto-arrange windows

comment:14 Changed 8 years ago by bennylp

(In [3799]) Misc (re #1370): fixed change video capture device for a call implementation

comment:15 Changed 8 years ago by bennylp

(In [3800]) Misc (re #1370): pjsua hide preview window when setting preview off

comment:16 Changed 8 years ago by nanang

(In [3801]) Misc (re #1370): disable H263 codec for RTP communication (was enabled to test whether it can use H263-1998 packetization).

comment:17 Changed 8 years ago by bennylp

(In [3802]) Misc (re #1370): limit the number of error messages caused by error in send_rtp()

comment:18 Changed 8 years ago by bennylp

(In [3805]) Set default H.263 bandwidth to 128Kbps instead of 1Mbps (re #1370)

comment:19 Changed 8 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.