Opened 8 years ago

Closed 8 years ago

#1252 closed defect (fixed)

Miscellaneous fixes

Reported by: bennylp Owned by: bennylp
Priority: minor Milestone: release-1.12
Component: common Version: 1.x-branch
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Miscellaneous and minor fixes here.

Change History (22)

comment:1 Changed 8 years ago by bennylp

(In [3561]) Misc (re #1252): fixed the assertion when jbuf_set_adaptive() is called with fixed jbuf parameters

comment:2 Changed 8 years ago by bennylp

(In [3599]) Re #1252 (Misc): bug in configure script, should put whitespace after gcc -o. This is fine on most gcc targets but rejected on some iPhone builds

comment:3 Changed 8 years ago by bennylp

(In [3600]) Re #1252 (misc fixes): fixed encoding of nc parameter in the HTTP client that caused authentication to fail (thanks Johan Lantz for the pointer)

comment:4 Changed 8 years ago by bennylp

(In [3603]) Misc (re #1252): updated icedemo help menu to make it clear that ice negotiation should be started immediately on the remote end. Thanks Andrés Suero for the suggestion

comment:5 Changed 8 years ago by bennylp

(In [3604]) Misc (re #1252): prevent assertion caused by bad account when scanning accounts for presence timer update. Thanks Matt DiMeo? for the patch

comment:6 Changed 8 years ago by bennylp

(In [3611]) Misc (re #1252): fixed potential crash if pjmedia_aud_dev_cap_name() is called with invalid capability

comment:7 Changed 8 years ago by bennylp

(In [3673]) Misc (re #1252): wrong doxygen documentation on the key argument of pj_hash_set, which said that it has to be valid throughout the duration of the entry. This is no longer true. Thanks Johan Lantz for pointing this out.

comment:8 Changed 8 years ago by bennylp

(In [3759]) Added endianness test in pjlib-test (Misc, re #1252)

comment:9 Changed 8 years ago by bennylp

(In [3760]) Added missing PJ_STUN_SOCK_MAPPED_ADDR_CHANGE name to pj_stun_sock_op_name. Thanks Howard Lin for the report (misc, re #1252)

comment:10 Changed 8 years ago by bennylp

(In [3761]) Fixed sockaddr address comparison error with memcmp, and use pj_sockaddr_cmp() instead. Thanks Howard Lin for the report (misc, re #1252)

comment:11 Changed 8 years ago by bennylp

(In [3765]) Another fix to pj_stun_sock_op_name() to support PJ_STUN_MAPPED_ADDR_CHANGE. Thanks Howard Lin for the report! (re #1252 (misc))

comment:12 Changed 8 years ago by bennylp

(In [3766]) Remove default endianness for bi-endian systems such as MIPS, ARM, and PowerPC, and raise compilation error instead. Thanks Howard Lin for the suggestion (misc, re #1252)

comment:13 Changed 8 years ago by nanang

In r3809: Wrong APS/VAS frame header generation for AMR silence/NO_DATA frame caused by using wrong 'OR' operator, was logical 'OR' instead of bitwise (thanks Johan Lantz for the report).

comment:14 Changed 8 years ago by ming

(In [3820]) Re #1252: Add PJLIB endianness preprocessor macro definition in autoconf

comment:15 Changed 8 years ago by ming

(In [3821]) Re #1252: Add the definition of PJ_AUTOCONF in ipjsua

comment:16 Changed 8 years ago by bennylp

(In [3822]) Set correct endianness for Windows Mobile and Symbian (re #1252, r3766)

comment:17 Changed 8 years ago by bennylp

(In [3828]) Misc (re #1252): fixed misleading doxygen documentation that says app may instantiate multiple instances of SIP endpoint

comment:18 Changed 8 years ago by bennylp

(In [3831]) Misc: failed to create CSV file with TRACE_JB feature in stream.c because Linux does not seem to create the file if it is opened with fopen(, "r+b") and the file does not exist yet. Thanks Dan for the patch (re #1252)

comment:19 Changed 8 years ago by bennylp

(In [3845]) Misc (re #1252): error compiling the IPP wrapper if AMR-WB is enabled but AMR-NB is disabled. Thanks Olle Frimanson for the report

comment:20 Changed 8 years ago by bennylp

(In [3846]) WAV playback is cut in the end if pjmedia_wav_player_port_set_pos() is called. Thanks Eize Slange for the patch (re #1252)

comment:21 Changed 8 years ago by ming

(In [3868]) Re #1252 (misc): Add codec initialization before opening it in pjmedia stream

comment:22 Changed 8 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.