Opened 8 years ago

Closed 8 years ago

#1232 closed defect (fixed)

Possible memory corruptions caused by pjsua_acc_modify() (thanks Viktor Krikun for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.10
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

The pjsua_acc_modify() function sets acc->display, acc->user_part, and acc->srv_domain directly from the supplied arguments without cloning them first, which cause the value to be invalid if the original arguments are destroyed.

Various symptoms of this bug include:

  • crash in pjsip_contact_hdr_print()
  • assertion on pjsua_acc.c:1189: "pj_assert(contact_hdr != NULL);" because the function failed to parse the account's Contact header.

Change History (1)

comment:1 Changed 8 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

(In [3538]) Fixed #1232: Possible memory corruptions caused by pjsua_acc_modify() (thanks Viktor Krikun for the report)

Note: See TracTickets for help on using tickets.