Opened 9 years ago

Closed 9 years ago

#1189 closed defect (duplicate)

Click noise produced by the jitter buffer when it progressively discard audio frames to improve latency (thanks Bogdan Krakowski for the patch)

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-1.10
Component: pjmedia Version: trunk
Keywords: PROGRESSIVE_DISCARD Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

The jitter buffer has an algorithm to discard few frames to improve latency when its contents are exceeding certain limit. This algorithm is called progressive discard and is enabled by default.

Unfortunately, this discard operation causes click noise to be produced, since the PCM wave signal of the next frame is no longer aligned with the previous frame.

This patch proposes dropping the next frame after the discarded frame, to cause invocation of the PLC, which would produce smoother wave signal than the original algorithm, thereby removing the click noise.

Attachments (1)

ticket-1189.patch (2.1 KB) - added by bennylp 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by bennylp

comment:1 Changed 9 years ago by bennylp

  • Description modified (diff)

comment:2 Changed 9 years ago by bennylp

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1188

Note: See TracTickets for help on using tickets.