Opened 9 years ago

Closed 9 years ago

#1084 closed defect (worksforme)

Invalid negotiated codec after SDP negotiation

Reported by: bennylp Owned by: nanang
Priority: normal Milestone: release-1.7
Component: pjmedia Version: trunk
Keywords: sipit26 Cc:
Backport to 1.x milestone: Backported:

Description

Scenario:

  • we receive INVITE
  • we send 200/OK with G.722.1 (pt=119) as the selected codec
  • call is confirmed, media is OK
  • we disabled all codecs except G.722 (pt=9)
  • we send UPDATE
  • we receive 401, we resend UPDATE
  • we receive 200/OK for UPDATE, with G.722 codec (pt=9) in the answer
  • at this point, we should be using G.722 codec (pt=9) in the media, but it looks like we're still expecting G.722.1:
    09:29:01.429  strm0x12ebca8  Bad RTP pt 9 (expecting 119)
    

Attachments (1)

badrtpptlog.txt (140.2 KB) - added by bennylp 9 years ago.

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by bennylp

comment:1 Changed 9 years ago by bennylp

  • Resolution set to worksforme
  • Status changed from new to closed

Unable to reproduce this. Closing the ticket for now.

Note: See TracTickets for help on using tickets.