Opened 10 years ago

Closed 9 years ago

#1063 closed defect (worksforme)

Audio stutter when using audio switchboard with narrowband codec (thanks Bogdan Krakowski for the report)

Reported by: bennylp Owned by: bennylp
Priority: normal Milestone: release-1.7
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp)

Audio stutter is observed when configuring pjsua to use audio switchboard instead of the default conference bridge, and when narrowband clock rate is used by the media (for example, play file).

To reproduce:

  1. enable switchboard, by declaring this in config_site.h:
    #define PJMEDIA_CONF_USE_SWITCH_BOARD	1
    
  2. run pjsua to stream file
    $ pjsua --null-audio --clock-rate --play-file pjsua8.wav --auto-play --auto-answer 200
    
  3. run another pjsua and call the pjsua "server":
    $ pjsua --dis-codec * --add-codec pcma --local-port 5080 sip:localhost
    

This was tested on Linux Ubuntu 09.10 64bit.

Change History (2)

comment:1 Changed 10 years ago by bennylp

  • Description modified (diff)

Edited: playing back local file is fine.

comment:2 Changed 9 years ago by ming

  • Resolution set to worksforme
  • Status changed from new to closed

Tested on various platforms (Mac OSX 10.6.2, Ubuntu 64, Vista 32&64, iPhone OS 3.1.2) and couldn't reproduce the stuttering.
Codec used: PCMA @ 8KHz.
PJSIP versions: 1.5 and 1.6 (svn trunk)
Testing methods: make call and file streaming

Note: See TracTickets for help on using tickets.