Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1050 closed enhancement (fixed)

Build configurations for iPhone OS

Reported by: ming Owned by: bennylp
Priority: normal Milestone: release-1.7
Component: applications Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

We need to modify PJSIP build configurations to successfully compile on iPhone OS

Attachments (2)

iPhone-guide.txt (2.1 KB) - added by ming 10 years ago.
configure-diff.txt (1.1 KB) - added by ming 10 years ago.

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by ming

Changed 10 years ago by ming

comment:1 Changed 10 years ago by bennylp

(In [3166]) Re #1050: added iPhone specific settings in config_site_sample.h

comment:2 Changed 10 years ago by bennylp

  • Resolution set to fixed
  • Status changed from new to closed

(In [3168]) Support for iPhone tools in the build system:

  • more flexible redeclaration of build tools. Now users may override build tools with environment variables, e.g. CC, AR, RANLIB, etc.
  • added configure-iphone: configure wrapper for iphone
  • tested with iPhone 2.x SDK

This closes #1050

comment:3 Changed 10 years ago by bennylp

(In [3169]) Re #1050: fixed failure in configure script if iPhone binutils/compiler are not in the PATH. They are called with their full paths now.

comment:4 Changed 10 years ago by bennylp

(In [3170]) Re #1050: automatic selection of ARM compiler to use based on the SDK. No need to create symbolic links to gcc now.

comment:5 Changed 10 years ago by bennylp

(In [3171]) Re #1050: removed -arch armv6 option from the default CFLAGS generated by configure-iphone, as this is rejected by gcc-4.2.1 that comes with iPhone-3.2 SDK.

comment:6 Changed 10 years ago by ming

  • Milestone changed from iphone-branch to release-1.7
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from iphone-branch to trunk

comment:7 Changed 10 years ago by ming

  • Resolution set to fixed
  • Status changed from reopened to closed

In r3175, merged into the main trunk.

comment:8 Changed 10 years ago by bennylp

  • Type changed from task to enhancement

comment:9 Changed 10 years ago by bennylp

(In [3176]) Re #1050: fixed aconfigure error caused by iPhone merging

Note: See TracTickets for help on using tickets.