Ticket #1034 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Crash on accepting a call with no codec in the SDP offer

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-1.6
Component: pjsip Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description (last modified by bennylp) (diff)

Steps to reproduce:

  1. run two pjsua instance
  2. in the caller, disable all codecs, i.e: 'Cp' then '* 0'
  3. caller makes call
  4. callee accepts the call
  5. callee will crash with stack trace similar to the following:
 pjsua-i386-Win32-vc8-Debug.exe!reset_pool(pj_pool_t * pool=0x0255a208)  Line 249 + 0x3 bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!pj_pool_reset(pj_pool_t * pool=0x0255a208)  Line 276 + 0x9 bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!inv_negotiate_sdp(pjsip_inv_session * inv=0x02559fdc)  Line 1507 + 0xc bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!process_answer(pjsip_inv_session * inv=0x02559fdc, int st_code=200, pjsip_tx_data * tdata=0x0255bdac, const pjmedia_sdp_session * local_sdp=0x00000000)  Line 1764 + 0x9 bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!pjsip_inv_answer(pjsip_inv_session * inv=0x02559fdc, int st_code=200, const pj_str_t * st_text=0x00000000, const pjmedia_sdp_session * local_sdp=0x00000000, pjsip_tx_data * * p_tdata=0x0018c3cc)  Line 1904 + 0x15 bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!pjsua_call_answer(int call_id=0, unsigned int code=200, const pj_str_t * reason=0x00000000, const pjsua_msg_data * msg_data=0x0018eca0)  Line 1393 + 0x1a bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!console_app_main(const pj_str_t * uri_to_call=0x0070e908)  Line 3511 + 0x1c bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!app_main()  Line 4733 + 0xa bytes	C
 pjsua-i386-Win32-vc8-Debug.exe!main(int argc=1, char * * argv=0x022520e8)  Line 88	C

Change History

comment:1 Changed 9 years ago by bennylp

Could not reproduce this with the latest revision (r3082), on Linux. When callee answers with 200, the library correctly answers with 488/Not Acceptable.

comment:2 Changed 9 years ago by bennylp

  • Description modified (diff)

comment:3 Changed 9 years ago by bennylp

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in r3091

Note: See TracTickets for help on using tickets.