Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1028 closed enhancement (fixed)

Implement pjsua_codec_set_param()

Reported by: nanang Owned by: bennylp
Priority: normal Milestone: release-1.6
Component: pjsua-lib Version: trunk
Keywords: Cc:
Backport to 1.x milestone: Backported:

Description

Currently the API is there with empty implementation.

Change History (6)

comment:1 Changed 9 years ago by nanang

In r3074:

  • Added new API pjmedia_codec_mgr_set_default_param() to set/update default codec parameter and implemented pjsua_codec_set_param() based on it.
  • Added mutex in codec manager to protect states manipulations.
  • Modified API pjmedia_codec_mgr_init() to add pool factory param, pool is needed to allocate mutex and codec params.
  • Added new API pjmedia_codec_mgr_destroy(), e.g: to release pools.

Minor/related updates:

  • Updated passthrough codec AMR to regard peer's mode-set setting.
  • Fixed VAS audio device to apply AMR encoding bitrate setting.
  • Fixed IPP codec codec_open() to update AMR bitrate info (for stream) when AMR encoding bitrate is not using the default, e.g: requested by peer via format param 'mode-set' in SDP.

comment:2 Changed 9 years ago by bennylp

In r3075:

  • Undo r3074 above as it is missing updated codec.h hence causing build errors (thanks Michael Bradley Jr for the report)

comment:3 Changed 9 years ago by nanang

In r3078:

  • Recommit r3074 with updated codec.h.

comment:4 Changed 9 years ago by nanang

In r3080:

  • Minor fixed missing pjmedia_codec_mgr_destroy() in pjmedia_endpt_destroy().

comment:5 Changed 9 years ago by nanang

  • Resolution set to fixed
  • Status changed from new to closed

In r3083:

  • Updated codecs docs, more detail info about codec settings.

comment:6 Changed 9 years ago by bennylp

In r3100:

  • fixed compile error caused by corrupted version of passthrough.c when re-commiting r3074 (in r3078).

(Note: this changeset was originally done by Nanang, recheckedin here due to moving svn repository and trac to new location)

Note: See TracTickets for help on using tickets.