Ignore:
Timestamp:
Oct 7, 2016 5:49:14 AM (3 years ago)
Author:
ming
Message:

Re #1941: Add support to specify min iOS versions in configure-iphone and update the default for ipjsua sample app

File:
1 edited

Legend:

Unmodified
Added
Removed
  • pjproject/trunk/configure-iphone

    r5150 r5453  
    1919  echo "             SDK." 
    2020  echo "  ARCH       Optional flags to specify target architecture, e.g." 
    21   echo "             ARCH='-arch armv6'. Default is armv7." 
     21  echo "             ARCH=\"-arch armv6\". Default is armv7." 
     22  echo "  MIN_IOS    Optional flags to specify minimum supported iOS" 
     23  echo "             versions, e.g. MIN_IOS=\"-miphoneos-version-min=10.0\". " 
     24  echo "             Default is 7.0." 
    2225  echo "" 
    2326  exit 0 
     
    116119export ARCH_VAL=`echo ${ARCH} | sed 's/\-arch //' | sed -e 's/^[ \t]*//;s/[ \t]*$//' ` 
    117120 
     121if test "${MIN_IOS}" = ""; then 
     122  MIN_IOS="7.0" 
     123  echo "$F: MIN_IOS is not specified, choosing ${MIN_IOS}" 
     124  CFLAGS="${CFLAGS} -miphoneos-version-min=${MIN_IOS}" 
     125  LDFLAGS="${LDFLAGS} -miphoneos-version-min=${MIN_IOS}" 
     126fi 
     127 
    118128# Set CXX if not set 
    119129if test "${CXX}" = ""; then 
Note: See TracChangeset for help on using the changeset viewer.