Ignore:
Timestamp:
Nov 10, 2015 10:36:14 AM (7 years ago)
Author:
nanang
Message:

Re #1896: Updated default audio device backends: mingw uses WMME, linux/*nix uses alsa (if available).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • pjproject/trunk/pjmedia/build/os-auto.mak.in

    r5197 r5199  
    5757#   - pa_old_darwinos:  PortAudio on MacOSX (old CoreAudio, for OSX 10.2) 
    5858#   - pa_win32:         PortAudio on Win32 (WMME) 
    59 #   - ds:               Win32 DirectSound (dsound.c) 
     59#   - win32:            Win32 MME (wmme_dev.c) 
     60#   - coreaudio:        MaxOSX CoreAudio (coreaudio_dev.m) 
     61#   - alsa:             Unix ALSA (alsa_dev.c) 
    6062#   - null:             Null sound device (nullsound.c) 
    6163#   - external:         Link with no sounddev (app will provide) 
     
    212214 
    213215# 
     216# Unix specific 
     217# 
     218ifneq ($(findstring alsa,$(AC_PJMEDIA_SND)),) 
     219export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_ALSA=1 \ 
     220                 -DPJMEDIA_AUDIO_DEV_HAS_PORTAUDIO=0 \ 
     221                 -DPJMEDIA_AUDIO_DEV_HAS_WMME=0 
     222endif 
     223 
     224# 
    214225# Windows specific 
    215226# 
    216227ifneq ($(findstring win32,$(AC_PJMEDIA_SND)),) 
    217 export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_WMME=1 
     228export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_WMME=1 \ 
     229                 -DPJMEDIA_AUDIO_DEV_HAS_PORTAUDIO=0 
    218230else 
    219231export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_WMME=0 
Note: See TracChangeset for help on using the changeset viewer.