Changes between Version 1 and Version 2 of Migration From 0.5 Version To 0.6 Version


Ignore:
Timestamp:
Apr 6, 2007 3:56:50 PM (12 years ago)
Author:
bennylp
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Migration From 0.5 Version To 0.6 Version

    v1 v2  
    11= Migration From 0.5 Version To 0.6 Version = 
    22 
    3 == New pjnath Library == 
     3== What's New and/or Changed == 
     4 
     5=== New pjnath Library === 
    46 
    57There is a new {{{pjnath}}} library for NAT traversal helper, containing ICE and new STUN implementation. This library is platform independent, and it depends only on {{{pjlib}}} and {{{pjlib-util}}}. 
     
    810 
    911 
    10 == Win32 IP Helper == 
     12=== Win32 IP Helper === 
    1113 
    1214PJLIB now has {{{ip_helper.h}}} file to enumerate local interface and local routing (needed by ICE). 
    1315 
    14 On Windows and WinCE, this requires application to link with '''Iphlpapi.lib'''. 
    1516 
    16 If you're using Visual Studio 6, you need to download '''Platform SDK''' from MSDN and add relevant include and library directory to VS6 options, since Iphlpapi.[h|lib] is not available with Visual Studio 6. 
     17== Migrating Your Application == 
    1718 
     19=== All Applications === 
     20 
     21If your application is based on PJSUA-LIB, you need to add '''PJNATH''' in your input library, 
     22 
     23=== All Windows and WinCE Applications === 
     24 
     25What need to change: 
     26 * On Windows and WinCE, the new IP helper abstraction requires application to link with '''IPHLPAPI.LIB'''. Note that IPHLPAPI.LIB is not shipped with Visual Studio 6 so you need to download Platform SDK to get this library. See the section about Visual Studio 6 below. 
     27 
     28 
     29=== Visual Studio 6 === 
     30 
     31If you're using Visual Studio 6, you need to: 
     32 * download '''Platform SDK''' from MSDN, and  
     33 * add relevant include and library directory to VS6 options, '''after''' the standard Visual Studio 6 include and library path. 
     34 
     35This is required because Iphlpapi.[h|lib] is not shipped with Visual Studio 6.