Changes between Version 24 and Version 25 of Getting-Started/Autoconf


Ignore:
Timestamp:
Sep 21, 2017 1:43:47 AM (2 years ago)
Author:
ming
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Getting-Started/Autoconf

    v24 v25  
    3636 1. [http://www.libsdl.org/ SDL] '''version 2.0''' 
    3737 1. libyuv (Recommended) for format conversion and video manipulation. Follow the instructions in ticket #1937 (or ticket #1776 if you are using PJSIP 2.5.1 or older). Alternatively, you can use ffmpeg as explained below. 
    38  1. OpenH264 (Recommended): Follow the instructions in ticket #1758 (or ticket #1947 if you use PJSIP version 2.6 or above). Alternatively, you can use ffmpeg as explained below. 
    39  1. [http://ffmpeg.org/ ffmpeg] development library. ffmpeg is used for format conversion and video manipulation; as well as video codecs: H.264 (together with libx264) and H263P/H263-1998. So, if you already use libyuv AND OpenH264, and you don't need H.263, then this is optional. We tested with ffmpeg version 1.x (1.2.5) to 0.x (from 0.5.1 (from circa 2009) to 0.10). Since #1897 we have added support for ffmpeg 2.8, however note that on applying the ticket, older ffmpeg will no longer be supported. 
    40     To enable H.264 support in ffmpeg (this is not required if you already have OpenH264): 
     38 1. OpenH264 (Recommended): Follow the instructions in ticket #1758 (or ticket #1947 if you use PJSIP version 2.6 or above). Alternatively, you can use !VideoToolbox (only for Mac) or ffmpeg as explained below. 
     39 1. !VideoToolbox (for Mac only, supported since PJSIP version 2.7), define this in your config_site.h: {{{#define PJMEDIA_HAS_VID_TOOLBOX_CODEC 1}}} 
     40 1. [http://ffmpeg.org/ ffmpeg] development library. ffmpeg is used for format conversion and video manipulation; as well as video codecs: H.264 (together with libx264) and H263P/H263-1998. So, if you already use libyuv AND H.264 (OpenH264 or !VideoToolbox), and you don't need H.263, then this is optional. We tested with ffmpeg version 1.x (1.2.5) to 0.x (from 0.5.1 (from circa 2009) to 0.10). Since #1897 we have added support for ffmpeg 2.8, however note that on applying the ticket, older ffmpeg will no longer be supported. 
     41    To enable H.264 support in ffmpeg (this is not required if you already have H.264 codec (via OpenH264 or !VideoToolbox)): 
    4142    - You need newer releases (October 2011 onwards), and it needs libz too. On Mac OS X: You may need to rebuild libbz2 if you have an old libbz2 for older system. 
    4243    - Build with at least: