Changes between Initial Version and Version 2 of Ticket #1457


Ignore:
Timestamp:
Mar 6, 2012 7:54:37 AM (10 years ago)
Author:
nanang
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1457

    • Property Status changed from new to closed
    • Property Resolution changed from to fixed
  • Ticket #1457 – Description

    initial v2  
    11Original report can be found [http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/2012-March/014256.html here]. 
     2{{{ 
     3I am using PJSIP 1.12 with iPhone 5.0.. I am getting “Assertion 
     4failed: (sdp_remote && m_rem), function transport_encode_sdp, file 
     5../src/pjmedia/transport_srtp.c, line 1299.” every time I try to 
     6call certain numbers.. 
     7... 
     8the problem is when I call from iPhone to a PBX extension that is 
     9connected to the service.. and I I get the above error, to be specific 
     10the code crash only when I pick up the call from that extension.. 
     11 
     12Snippet log: 
     13... 
     14(normal outgoing initial INVITE until ACK ..) 
     15... 
     1615:31:31.393   pjsua_core.c  RX 703 bytes Request msg UPDATE/cseq=102 
     17 (rdata0x9061bc) from tcp 10.50.0.4:5060: 
     18UPDATE sip:77999991@10.50.1.10:5060;transport=TCP;ob SIP/2.0 
     19Via: SIP/2.0/TCP 10.50.0.4:5060;branch=z9hG4bK4b370dd7;rport 
     20Max-Forwards: 70 
     21From: sip:9874@10.50.0.4;tag=as5a9c25b2 
     22To: sip:77999991@10.50.0.4;tag=PxbkZXr7smjwglhT87678rIypjrr0tln 
     23Contact: <sip:9874@10.50.0.4:5060;transport=TCP> 
     24Call-ID: F3a8f5vZu0f6JEJFmlN5vIagy-P1De7h 
     25CSeq: 102 UPDATE 
     26User-Agent: TEST 
     27Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE,  
     28 NOTIFY, INFO, PUBLISH 
     29Supported: replaces, timer 
     30X-asterisk-Info: SIP re-invite (External RTP bridge) 
     31Content-Type: application/sdp 
     32Content-Length: 102 
     33  
     34v=0 
     35o=root 2007926168 2007926170 IN IP4 172.16.201.225 
     36s=TEST 
     37c=IN IP4 172.16.201.225 
     38t=0 0 
     39}}} 
    240 
    341Such reoffer should be just simply rejected and any existing session won't get updated.