Ignore:
Timestamp:
Mar 5, 2009 6:02:28 PM (11 years ago)
Author:
bennylp
Message:

Ticket #736 (aps-direct branch): implemented the compatibility layer for the old sound API

File:
1 edited

Legend:

Unmodified
Added
Removed
  • pjproject/branches/projects/aps-direct/pjmedia/src/pjmedia-audiodev/wmme_dev.c

    r2488 r2489  
    11501150        return PJ_SUCCESS; 
    11511151    } else { 
    1152         return PJ_ENOTSUP; 
     1152        return PJMEDIA_EAUD_INVCAP; 
    11531153    } 
    11541154} 
     
    11761176        return (mr==MMSYSERR_NOERROR)? PJ_SUCCESS :  
    11771177                                PJMEDIA_AUDIODEV_ERRNO_FROM_WMME_OUT(mr); 
    1178     } else { 
    1179         return PJ_ENOTSUP; 
    1180     } 
    1181  
    1182     return PJ_ENOTSUP; 
     1178    } 
     1179 
     1180    return PJMEDIA_EAUD_INVCAP; 
    11831181} 
    11841182 
Note: See TracChangeset for help on using the changeset viewer.