Changeset 1707


Ignore:
Timestamp:
Jan 18, 2008 6:36:53 PM (12 years ago)
Author:
bennylp
Message:

Added PJSIP_ESESSIONINSECURE error code in sip_errno to require that secure session shall be used

Location:
pjproject/branches/users/nanang/pjsip
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • pjproject/branches/users/nanang/pjsip/include/pjsip/sip_errno.h

    r1539 r1707  
    429429 */ 
    430430#define PJSIP_ESESSIONSTATE      (PJSIP_ERRNO_START_PJSIP+141)  /* 171141 */ 
    431  
     431/** 
     432 * @hideinitializer 
     433 * The feature being requested requires the use of secure session or  
     434 * transport. 
     435 */ 
     436#define PJSIP_ESESSIONINSECURE  (PJSIP_ERRNO_START_PJSIP+142)   /* 171142 */ 
    432437 
    433438/************************************************************ 
  • pjproject/branches/users/nanang/pjsip/src/pjsip/sip_errno.c

    r1539 r1707  
    115115    PJ_BUILD_ERR( PJSIP_ESESSIONTERMINATED, "INVITE session already terminated" ), 
    116116    PJ_BUILD_ERR( PJSIP_ESESSIONSTATE,      "Invalid INVITE session state" ), 
     117    PJ_BUILD_ERR( PJSIP_ESESSIONINSECURE,   "Require secure session/transport"), 
    117118 
    118119    /* SSL errors */ 
Note: See TracChangeset for help on using the changeset viewer.