Changeset 1514


Ignore:
Timestamp:
Oct 21, 2007 11:48:51 AM (11 years ago)
Author:
bennylp
Message:

Fixed compilation warning in sip_auth_client.c about unreachable code when AKA is not used (thanks Jim Gomes)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • pjproject/trunk/pjsip/src/pjsip/sip_auth_client.c

    r1500 r1514  
    491491 
    492492#if !PJSIP_HAS_DIGEST_AKA_AUTH 
    493                 pj_assert(!"PJSIP_HAS_DIGEST_AKA_AUTH is not enabled"); 
    494                 return PJSIP_EAUTHINAKACRED; 
     493                if (!PJSIP_HAS_DIGEST_AKA_AUTH) { 
     494                    pj_assert(!"PJSIP_HAS_DIGEST_AKA_AUTH is not enabled"); 
     495                    return PJSIP_EAUTHINAKACRED; 
     496                } 
    495497#endif 
    496498 
Note: See TracChangeset for help on using the changeset viewer.